UI Issue: Entity History Not Displaying from July 8 Onwards – US2 Cluster

Incident Report for Targetprocess

Resolved

The issue doesnt seem to be appearing on US2 Cluster anymore. Hence closing this incident
Posted Jul 09, 2025 - 05:43 UTC

Investigating

We are Currently Investigating.
Posted Jul 09, 2025 - 05:38 UTC
This incident affected: Portland data center (US2 cluster).