Issues on one of US servers
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 19:23 UTC
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 19:22 UTC
Investigating
We are currently investigating this issue.
Posted Nov 17, 2021 - 18:37 UTC
This incident affected: United States data center.