Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 01:00 UTC
Scheduled
We will be executing maintenance on our Global Transit Network controller. Targetprocess may be temporarily inaccessible or experience degraded performance during the maintenance window.
Posted Mar 14, 2025 - 14:34 UTC
This scheduled maintenance affected: Dublin data center (EU cluster, EU2 cluster, POVEU cluster).