Some accounts may not load in Dallas DC
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 12:31 UTC
Identified
The infrastructure team is working on restoring the access to the application
Posted Mar 10, 2021 - 11:49 UTC
This incident affected: United States data center.