Internal Server Error for some of the accounts
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 12, 2019 - 10:47 UTC
Identified
Users can face temporary issues while accessing an account
Posted 6 months ago. Apr 12, 2019 - 10:10 UTC
This incident affected: United States data center and European data center.