Service Desk partially unavailable in DAL cluster
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 15:33 UTC
Identified
We're working on fixing it
Posted Jan 16, 2020 - 15:09 UTC
This incident affected: United States data center.