Automation Rules and Integrations are unblocked and working properly. We are still working on resolving the issue for Metrics.
Posted Apr 23, 2025 - 16:41 UTC
Update
We are continuing to investigate this issue. We apologize for any inconvenience this interruption may have caused you.
Posted Apr 23, 2025 - 16:18 UTC
Investigating
Currently, you may experience delay in Automation Rule, Metrics, Integrations processing. We apologize for any inconvenience this interruption may have caused you.
Posted Apr 23, 2025 - 14:42 UTC
This incident affected: Dublin data center (EU2 cluster).