Performance Degradation / General Slowness - US Cluster
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 21:12 UTC
Update
This issue has been resolved.
Posted Jan 13, 2025 - 21:12 UTC
Update
We are continuing to investigate this issue.
Posted Jan 13, 2025 - 18:57 UTC
Investigating
We are investigating the issue
Posted Jan 13, 2025 - 16:51 UTC
This incident affected: Portland data center (US cluster).