Dallas DC: some accounts may experience issues with the application load
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 12:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2021 - 11:56 UTC
This incident affected: United States data center.