Performance degradation on EU2 cluster

Incident Report for Targetprocess

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 12:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 11:52 UTC

Investigating

We are currently experiencing some performance issue in EU2 cluster. We are currently investigating the issue.
Posted Feb 18, 2026 - 09:30 UTC
This incident affected: Europe (EU2 cluster).