Unplanned maintenance
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 10, 2019 - 10:27 UTC
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. Apr 10, 2019 - 08:29 UTC
Monitoring
Urgent maintenance is performed to ensure the highest level of security. All services are expected to be up and running by 10:00 UTC
Posted 4 months ago. Apr 10, 2019 - 08:29 UTC
This incident affected: United States data center.