Targetprocess Service Interruption for some of the accounts in Dallas data center
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 15:52 UTC
Investigating
The infrastructure team is currently investigating the issue
Posted Mar 03, 2023 - 15:39 UTC