Service Desk is not working for some customers in the US datacenter
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 11:47 UTC
Investigating
We are currently investigating the issue
Posted Jul 21, 2021 - 10:24 UTC
This incident affected: United States data center.