Intermittent issues with the authentication at European accounts
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 12:35 UTC
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 09:58 UTC
This incident affected: European data center.