Performance degradation on US cluster

Incident Report for Targetprocess

Resolved

No performance issues observed today - the incident is resolved.
Posted Jan 27, 2026 - 21:47 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 27, 2026 - 19:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 14:10 UTC

Investigating

We are investigating a performance issue due to high system load, which is causing delays in some system components.
Posted Jan 26, 2026 - 15:45 UTC
This incident affected: Americas (US cluster).