Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 04, 2024 - 07:00 UTC
Scheduled
We will be migrating the internal storage for the reporting module to a newer version. This migration will enable delivering an improved performance for the reporting module. The reports will be unavailable during the entire maintenance window.
Posted Mar 28, 2024 - 08:49 UTC
This scheduled maintenance affected: Portland data center (US cluster).