Email notifications outage

Incident Report for Targetprocess

Resolved

This incident has been resolved.
Posted Oct 02, 2023 - 18:21 UTC

Investigating

We are currently investigating this issue.
Posted Oct 02, 2023 - 13:08 UTC
This incident affected: Dublin data center (EU2 cluster).