Performance issues with some accounts hosted in Amsterdam cluster.
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 09:14 UTC
Investigating
We are currently investigating this issue.
Posted Jun 22, 2022 - 07:21 UTC
This incident affected: Amsterdam data center.