Intermittent issues with the connection to US accounts
Incident Report for Targetprocess
Resolved
The incident has ben solved
Posted Dec 27, 2019 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 27, 2019 - 14:55 UTC
Investigating
We are currently investigating this issue.
Posted Dec 27, 2019 - 14:29 UTC
This incident affected: United States data center.