Performance issue in Portland data center.

Incident Report for Targetprocess

Resolved

This incident has been resolved.
Posted Jul 08, 2024 - 13:19 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2024 - 10:19 UTC

Investigating

We are currently investigating this issue.
Posted Jul 08, 2024 - 09:08 UTC
This incident affected: Portland data center (US cluster).