Some accounts in Dallas datacenter are not loading
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 09:19 UTC
Investigating
Infrastructure team is currently investigating the issue
Posted Apr 12, 2021 - 08:10 UTC
This incident affected: United States data center.