Downtime affecting some of the customers
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 28, 2019 - 16:24 UTC
Investigating
Problem accessing some of the accounts in this data center. Our infrastructure team is already looking into it.
Posted about 2 months ago. Mar 28, 2019 - 16:22 UTC
This incident affected: United States data center.