Global performance issues

Incident Report for Targetprocess

Resolved

This incident has been resolved, all systems should now be operational.
Posted Aug 05, 2025 - 13:30 UTC

Monitoring

This issue has been mitigated, and we are currently monitoring.
Posted Aug 05, 2025 - 12:36 UTC

Investigating

We are currently working on the issue.
Posted Aug 05, 2025 - 12:12 UTC
This incident affected: Sydney data center (APAC cluster), Dublin data center (EU cluster, EU2 cluster, POVEU cluster), and Portland data center (US cluster, US2 cluster).