We are currently experiencing some performance issue in EU2 cluster. We are currently investigating the issue.

Incident Report for Targetprocess

Resolved

Performance has been stable for the past two hours, and the incident is now considered resolved.
Posted Feb 23, 2026 - 16:41 UTC

Monitoring

The issue has now been fully mitigated after the required measures were applied. We will continue to closely monitor system performance.
Posted Feb 23, 2026 - 15:19 UTC

Update

The issue has been partially mitigated. Performance has improved, but some elevated wait times may still occur. Our team continues to investigate and closely monitor the situation.
Posted Feb 23, 2026 - 14:06 UTC

Identified

We have identified the cause as increased database query compilation time. Our engineering team is actively working on a fix and closely monitoring the EU2 cluster.
Posted Feb 23, 2026 - 12:33 UTC

Update

We applied database configuration optimizations on the cluster. Performance has improved, but some elevated wait times are still observed. Investigation and monitoring are ongoing.
Posted Feb 23, 2026 - 10:53 UTC

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 09:56 UTC

Investigating

We are currently investigating this issue.
Posted Feb 23, 2026 - 08:52 UTC
This incident affected: Europe (EU2 cluster).