Issues with logging into account for EU users
Incident Report for Targetprocess
Resolved
The incident with not being able to log in is resolved
Posted May 26, 2020 - 15:23 UTC
Identified
Only people who have not been logged into account already are experiencing the issue. Our DevOps team is already fixing it.
Posted May 26, 2020 - 14:55 UTC
This incident affected: European data center.