Targetprocess Service Interruption
Incident Report for Targetprocess
Resolved
We have resolved the issue and your services have been restored.

If you are still experiencing issues, please create a request in the Support Portal https://servicedesk.targetprocess.com/
Posted Mar 27, 2024 - 22:19 UTC
Update
We are still actively working on a fix for the ongoing issue.
Posted Mar 27, 2024 - 21:30 UTC
Update
We are actively working on a fix for the ongoing issue.
Posted Mar 27, 2024 - 20:22 UTC
Update
We are still experiencing an issue which may cause a degradation of service. We continue to work diligently to resolve this and will provide regular updates on our progress until we have done so.

Currently, you may experience performance issues. We apologize for any inconvenience this interruption may have caused you.
Posted Mar 27, 2024 - 19:22 UTC
Investigating
We are currently experiencing an issue which may cause a degradation of service. We are working diligently to resolve this and will provide regular updates on our progress.

Currently, you may experience performance issues. We apologize for any inconvenience this interruption may have caused you.
Posted Mar 27, 2024 - 18:18 UTC
This incident affected: Portland data center (US cluster, US2 cluster).