We were experiencing an issue with the application which are hosted European cluster. We have resolved this issue
Incident Report for Targetprocess
Resolved
This Incident has been resolved
Posted May 02, 2022 - 07:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2022 - 07:28 UTC
This incident affected: Amsterdam data center.