The issue has been identified and a fix is being implemented.
Posted Nov 06, 2023 - 11:01 UTC
Investigating
We are currently experiencing an issue with share view functionality. We are working diligently to resolve this and will provide regular updates on our progress.
We apologize for any inconvenience this interruption may have caused you.
Posted Nov 06, 2023 - 04:45 UTC
This incident affected: Sydney data center (APAC cluster), Dublin data center (EU cluster, EU2 cluster, POVEU cluster), and Portland data center (US cluster, US2 cluster).