Jira and AzDO integration services - Performance Degradation on US2 cluster

Incident Report for Targetprocess

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 20:25 UTC

Update

We are continuing to investigate this issue further.
Posted Aug 01, 2025 - 19:39 UTC

Update

We are continuing to investigate this issue.
Posted Aug 01, 2025 - 18:39 UTC

Investigating

Currently, you may experience a delay in Integrations processing. We apologize for any inconvenience this interruption may have caused you. We are currently investigating this issue.
Posted Aug 01, 2025 - 17:39 UTC
This incident affected: Portland data center (US2 cluster).