Email notifications are delivered with a delay
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 10:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2023 - 13:42 UTC
Investigating
The issue is intermittent. Only some of the notifications are delayed.
Posted Jun 01, 2023 - 12:55 UTC
This incident affected: Portland data center (US cluster).