Performance degradation on some account in EU DC
Incident Report for Targetprocess
Resolved
This incident has been resolved.
Posted Jan 21, 2022 - 18:46 UTC
Investigating
We are currently investigating this issue.
Posted Jan 21, 2022 - 08:56 UTC
This incident affected: Amsterdam data center.