Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 07:00 UTC
Scheduled
We will be executing maintenance on our Global Transit Network controller. Targetprocess may be temporarily inaccessible or experience degraded performance during the maintenance window.
Posted Mar 18, 2025 - 17:11 UTC
This scheduled maintenance affected: Sydney data center (APAC cluster).