Network issues on the hosting provider
Incident Report for Targetprocess
Postmortem

Network speed degradation was observed on all the servers. As a result, some users were experiencing slowness of Targetprocess application.

Posted Jul 09, 2020 - 13:40 UTC

Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 23:45 UTC
Identified
We have received and information that our hosting provider experience network issues
Posted Jun 22, 2020 - 20:28 UTC
This incident affected: United States data center, European data center, and Australian Data center.