Issue with opening cards on US and EU clusters
Incident Report for Targetprocess
Resolved
The issue has been solved.
Posted May 26, 2021 - 13:56 UTC
Update
We are continuing to investigate this issue.
Posted May 26, 2021 - 12:48 UTC
Investigating
We are currently investigating this issue
Posted May 26, 2021 - 12:22 UTC
This incident affected: United States data center and European data center.