Slowness in Dublin (EU2) datacenter

Incident Report for Targetprocess

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 11:11 UTC

Investigating

We are currently investigating this issue.
Posted Sep 28, 2023 - 08:28 UTC
This incident affected: Dublin data center (EU2 cluster).