Issues with accessing accounts in US datacenter
Incident Report for Targetprocess
Resolved
The issue has been resolved
Posted May 20, 2021 - 11:24 UTC
Identified
There are connectivity issues on the side of our network provider which may affect some accounts in the US cluster. They are working on it
Posted May 20, 2021 - 07:43 UTC
Investigating
Our infrastructure team is currently working on the issue
Posted May 20, 2021 - 07:27 UTC
This incident affected: United States data center.